Excel Ship Designer

Arkathan

Cosmic Mongoose
Are you typing 1% of hull in there? Valid entries are whole numbers, 0+.
No idea where that would be coming from, unless it is inputting data validation notes.


Graple example.png
 

IanBruntlett

Cosmic Mongoose
weird, the grapple problem seems to only be a problem in libreoffice. It works fine in Windows and Excel but on Linux and LibreOffice I get this. I would not worry about it. I do not imagine there are that many Linux users and even if there are that is literally the only place that does not appear to function (that I noticed anyway)
Have you tried it on Windows and LibreOffice? As for not many Linux users out there - I am one - but intend to get hold of the next High Guard before I play around with ship design. For some years now I have been refurbishing old unwanted computers and put Linux on them. I know of another volunteer who does the same. And there's more of us, spread across the globe...
 

Arkathan

Cosmic Mongoose
Have you tried it on Windows and LibreOffice? As for not many Linux users out there - I am one - but intend to get hold of the next High Guard before I play around with ship design. For some years now I have been refurbishing old unwanted computers and put Linux on them. I know of another volunteer who does the same. And there's more of us, spread across the globe...
This is one reason I've been using an old version of Excel and staying away from the features like buttons (once I found out they didn't work on other systems)
 

k0k0pelli

Banded Mongoose
Have you tried it on Windows and LibreOffice? As for not many Linux users out there - I am one - but intend to get hold of the next High Guard before I play around with ship design. For some years now I have been refurbishing old unwanted computers and put Linux on them. I know of another volunteer who does the same. And there's more of us, spread across the globe...
I have not but sure can. I will set it up over the weekend and report.

I have been using Linux as my primary OS since about 2000. I am a programmer by trade and it fits my workflow but I am sort of used to assuming I am in the minority when it comes to non-programming tasks.
 

AndrewW

Cosmic Mongoose
I have been using Linux as my primary OS since about 2000. I am a programmer by trade and it fits my workflow but I am sort of used to assuming I am in the minority when it comes to non-programming tasks.
Last version of that other thing I used was 3.1. Mostly Linux, but used OS/2 before that.
 

k0k0pelli

Banded Mongoose
Are you typing 1% of hull in there? Valid entries are whole numbers, 0+.
No idea where that would be coming from, unless it is inputting data validation notes.


View attachment 887
to answer your question, no. if I add a "1" making the field "01" it says invalid value. If I delete the "0" and type a "1" then the field populates with the "% of Hull" automatically.
 

Arkathan

Cosmic Mongoose
to answer your question, no. if I add a "1" making the field "01" it says invalid value. If I delete the "0" and type a "1" then the field populates with the "% of Hull" automatically.
Try this:


I moved the "1% of Hull" out of that column (from the Repair Probes). Let's see if it ignores it now that it is in another column and stops trying to autofill from a previous entry. Let me know what happens, please.
 
Last edited:

k0k0pelli

Banded Mongoose
Try this:
Ship Designer

I moved the "1% of Hull" out of that column (from the Repair Probes). Let's see if it ignores it now that it is in another column and stops trying to autofill from a previous entry. Let me know what happens, please.
I still get the invalid value but it does not try to autofill any more.
I went ahead and filled out at least a row for each type of entry. the only ones that failed were the 2 grapples and the forced linkage apparatus. With any value other than "0" it gave me an invalid value error. for each of those three fields I tried "0", "1", "5", "0.3", and "d" I also tried "2" and "6" for the small and large grapples respectively (basically the tonnage for each)
I only did one row each of hangar bay, launch tubes, and recovery deck but put various values in all other rows.

1666395322555.png
 

k0k0pelli

Banded Mongoose
I did note it used the "X - Y tons" lines for autocomplete in the airlocks fields but a backspace cleared that without issue. It probably cleared the autocomplete for the "% hull" as well but I was still getting the invalid value so conflated the two.
 

Arkathan

Cosmic Mongoose
I still get the invalid value but it does not try to autofill any more.
I went ahead and filled out at least a row for each type of entry. the only ones that failed were the 2 grapples and the forced linkage apparatus. With any value other than "0" it gave me an invalid value error. for each of those three fields I tried "0", "1", "5", "0.3", and "d" I also tried "2" and "6" for the small and large grapples respectively (basically the tonnage for each)
I only did one row each of hangar bay, launch tubes, and recovery deck but put various values in all other rows.
Thanks for that.
Think I may have it.
Try this:

Current Version: 2022.10.20b
 
Last edited:

k0k0pelli

Banded Mongoose
Yeah, I only did 5 airlock lines (one for each option) and one line for the other repeat lines but everything seems to work.

Thanks for your patience and help!
 
Top