What do you need to play?

Discuss Mongoose RPGs here, such as the OGL rulebooks, Jeremiah, Armageddon 2089 and Macho Women with Guns
blue crane
Mongoose
Posts: 129
Joined: Mon Aug 18, 2003 5:58 pm

What do you need to play?

Postby blue crane » Sat Feb 14, 2004 9:09 pm

Do you require the D&D Player's Handbook to play? If so, then what edition? 3.0 or 3.5?

Thank you.

Regards,
Blue Crane
User avatar
August
Lesser Spotted Mongoose
Posts: 548
Joined: Thu Sep 25, 2003 5:46 pm

Postby August » Sat Feb 14, 2004 9:11 pm

To play Babylon 5, any copy of the Player's Handbook will do. The Pocket Player's Guide will also suffice, as will any copy of the basic 3.0 or 3.5 rules. The core game of B5 was written with 3.0 in mind as it was in production before 3.5 came out...

-August
"This is a blanket apology to every god I can think of and all the ones I don't know. I have no idea what I did or in which life I did it, but I am really sorry. Ummm, my bad."

Who is online

Users browsing this forum: No registered users and 40 guests